Dashboard Login Failure - Identified

Incident Report for DNSFilter

Postmortem

Dashboard Login Failure - Postmortem

Summary:
The system experienced a performance reduction that resulted in slower API response times and an unresponsive front-end dashboard. As a result, users encountered delays when interacting with the dashboard and during API calls.
Resolution:
 Our team identified the issue immediately and initiated an incident response. A hot fix addressing the root cause was developed, tested, and deployed the same day to restore normal service.
Next Steps:
 We are conducting a deeper review of how our systems interact with the database to identify opportunities for long-term optimization and to prevent similar issues in the future.

Posted Jul 15, 2025 - 09:19 EDT

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 13:04 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 14, 2025 - 09:52 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 14, 2025 - 09:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 08:45 EDT

Identified

Our engineering team has identified an issue that is preventing users from logging into the dashboard and is currently working to implement a fix. We will provide updated status as soon as possible.
Posted Jul 14, 2025 - 08:14 EDT
This incident affected: Dashboard (Front End UI, API) and Features (Data Export).