DNS Resolution is Intermittent - Investigating

Incident Report for DNSFilter

Resolved

Our connectivity is provided through an Internet Exchange (IX), essentially a shared hub that connects us with many other networks. If our own connection to the IX had gone down, it would have affected all customers equally, but that wasn't the case here.

Based on what we're seeing, it's possible that a subset of networks sharing the same infrastructure at the IX experienced a localized issue, which would explain why only some customers noticed a problem while others didn't. We want to be transparent that this is our best working theory rather than a confirmed root cause, as we don't have full visibility into that specific piece of infrastructure.

We also checked with our upstream provider, and they've confirmed that all systems on their end showed as healthy throughout this period.

We're continuing to monitor closely, and we'll update you if we learn anything further. Please let us know if you're still experiencing any issues.
Posted Sep 22, 2026 - 10:26 EDT

Monitoring

Resolution is back in and working; engineering is monitoring.
Posted Sep 22, 2026 - 08:26 EDT

Investigating

Our engineering team is currently investigating an issue that is causing DNS resolution to be Intermittent across the UK region and is currently working with our partners to resolve the situation.
Posted Sep 22, 2026 - 08:14 EDT
This incident affected: DNS1 Anycast Network (Europe) and DNS2 Anycast Network (Europe).