Windows Roaming Client 1.7.15 Auto-upgrade
Incident Report for DNSFilter
Resolved
The incident affecting auto-upgrade of Windows Roaming Client version 1.7.15 is now in resolved status.

We continue to advise customers that experienced a deployment error to uninstall and reinstall the Windows RC. Our QA and Engineering teams have completed their investigation of root cause and are planning a new release date with incorporated fixes.

DNSFilter's network remains fully operational.
Posted Jun 30, 2022 - 09:25 EDT
Monitoring
This incident is now in Monitoring status.

Earlier today, there was a service start failure for some customers upon auto-upgrading the Windows Roaming Client to the latest version (1.7.15). Our team removed this release from general availability and began to investigate.

Our Development team is working through a fix to this issue. If you are affected, you may immediately overcome the error by uninstalling and reinstalling the Windows RC.

DNSFilter's network remains fully operational.
Posted Jun 29, 2022 - 15:56 EDT
Update
We have paused the auto-upgrade process for Windows RC 1.7.15 as our team investigates failures for some customers to start the Roaming Client service after upgrade.

If you are affected by this issue, you are encouraged to remediate by ensuring that your installed .NET version is 4.5 or greater, and reinstalling the Windows Roaming Client.

Our DNS filtering network remains fully operational.
Posted Jun 29, 2022 - 12:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 29, 2022 - 10:49 EDT
Update
Auto-upgrade for Windows RC 1.7.15 remains paused as our team continues to investigate additional causes of failure to start the Windows Roaming Client service during upgrade.

If you are affected by this issue, you are encouraged to remediate by ensuring that your installed .NET version is 4.5 or greater, and reinstalling the Windows Roaming Client.

Our DNS filtering network is remains fully operational.
Posted Jun 29, 2022 - 10:48 EDT
Identified
After investigation, we believe the cause of auto-upgrade failure is limited to clients that are running an unsupported version of Microsoft .NET. The Windows RC requires .NET 4.5+ in order to run.

If you are affected by this issue, you are encouraged to remediate by installing .NET 4.5 or greater and reinstalling the Windows Roaming Client.
Posted Jun 29, 2022 - 09:39 EDT
Investigating
We are currently investigating a possible issue with the automatic upgrade to Windows Roaming Client 1.7.15 due to customer reports.

Our Operations team has paused the auto-upgrade process during the investigation.

DNS filtering is fully operational.
Posted Jun 29, 2022 - 09:04 EDT
This incident affected: Features (Roaming Clients).