We have identified the cause of the issue where traffic intended for our service via DNS2 is unexpectedly being routed to our DNS1 servers, which began on March 30th, 2025, at 18:10 UTC.
We are now monitoring the implementation of the solution. While investigating the initial misrouting, we currently observe no increase in latency.
Further updates on the resolution will be provided as they become available. Thank you for your patience.
Posted Mar 30, 2025 - 17:52 EDT
Investigating
We understand the recent DNS resolution disruptions may have caused inconvenience, and we sincerely apologize for any impact this has had on your operations. Please know maintaining a reliable service is a top priority for us, and we are actively working to resolve these issues as quickly as possible.
On March 30th, 2025, starting at 18:10 UTC, our systems detected traffic intended for our service via DNS2 was unexpectedly being routed to our servers handling traffic over DNS1.
While we are currently investigating the cause of this misrouting, we want to assure you that we are not observing any increase in latency at this time. Our team is engaged to examine this issue and implement a solution. We recognize the importance of keeping you informed and will provide further updates as soon as they are available.
Thank you for your patience and understanding as we work diligently to restore optimal service.
Posted Mar 30, 2025 - 16:16 EDT
This incident affected: DNS2 Anycast Network (North America, Europe).