Domain Categorization & System Load

Incident Report for DNSFilter

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 08:51 EDT

Monitoring

What Happened with Domain Categorization and System Load (e.g. msn.com )
-Some well-known domains like msn.com and started showing up as “uncategorized,” and our backend systems experienced a large spike in traffic. Here’s what we know:

What Happened:
-Some websites like msn.com temporarily lost their category labels due to them being treated as uncategorized in the system.
-Our platform automation tried to correct this but sent too many repeated requests at once, overloading internal systems.
-This caused delays in restoring correct category information, so some domains stayed uncategorized longer than expected.
-We’ve deployed a fix to reduce the load and are restoring normal behavior.

Key Customer Impact:
-Domains like msn.com appeared uncategorized because they dropped out of cache and couldn’t be reloaded reliably.
-This could affect content filtering accuracy, especially for high-traffic or policy-critical domains.
-No DNS resolution outages occurred, but policy behavior may have been incorrect.

Fix:
A fix has been implemented; however, due to caching, it may take 24–48 hours for affected domains to reflect the correct categorization.

Workaround:
In the meantime, you can either add the impacted domains to your allow list or temporarily allow uncategorized domains within your policy settings to avoid disruption.
Posted Jun 20, 2025 - 13:07 EDT
This incident affected: Features (Domain Categorization).