Resolution issues for *.adp.com
Incident Report for DNSFilter
Resolved
The issue with subdomains of adp.com not resolving has been resolved and workarounds that were implemented can be removed. If you need any further assistance please contact us at support@dnsfilter.com.
Posted Apr 07, 2023 - 09:05 EDT
Investigating
We are currently investigating an issue where subdomains of adp.com are intermittently not resolving with the Windows roaming client. We will provide updated status as soon as it becomes available.

Our current workaround is enabling DNS over TLS on the roaming client. This can be done via registry edit:

-If you are running the Retail version (DNSFilter Agent)
reg add “HKLM\Software\DNSFilter\Agent” /v UpstreamOrder /d “tcp-tls,udp,tcp”

-If you are running the Whitelabel version (DNS Agent)
reg add “HKLM\Software\DNSAgent\Agent” /v UpstreamOrder /d “tcp-tls,udp,tcp”

Another workaround for this issue includes passing the adp.com domains to a local resolver for resolution.

You can do this by adding apd.com to the local domains field in the dashboard found under Deployments > Roaming Clients > Local Domains, and selecting the site. From here on the left you can add adp.com as a local domain.

Please note this will need to be done for each site associated with roaming clients to work properly.

The change should take effect for the client on the next sync, or for faster results, on service restart.
Posted Apr 06, 2023 - 16:38 EDT
This incident affected: Features (Roaming Clients).