DNSFilter Dashboard Performance Issue - Identified

Incident Report for DNSFilter

Resolved

The cloud partner has resolved the issue on their end.

Our engineers have confirmed that both Anycast and DNSFilter APIs remained fully operational throughout the event.

No customer-facing impact or service degradation was observed.
Posted Oct 20, 2025 - 08:22 EDT

Identified

Our engineering team has identified an issue with our cloud partner that may cause the dashboard and API to have performance issues.

Our Anycast network is unaffected as of this time.

We will provide an updated status as soon as possible once the partner has resolved this issue.
Posted Oct 20, 2025 - 05:57 EDT
This incident affected: Dashboard (Front End UI, API).