DNS Resolution is Down - Investigating - EMEA

Incident Report for DNSFilter

Resolved

The issue is now resolved. Post-Mortem to follow.
Posted Apr 29, 2025 - 07:15 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2025 - 06:27 EDT

Monitoring

We are currently monitoring the region affected.
Posted Apr 29, 2025 - 06:21 EDT

Identified

Between the hours of 09:08 UTC and 09:47 UTC we experienced a significant higher latency than normal on specific London nodes. This impacted DNS resolution for customers that were routed to the London nodes. We have identified and remediated the issue and are currently monitoring.
Posted Apr 29, 2025 - 06:21 EDT

Investigating

Our engineering team is currently investigating an issue that is causing DNS resolution to be down and is currently working to implement a fix to resolve this problem. Updated status will be provided as soon as possible.
Posted Apr 29, 2025 - 06:17 EDT
This incident affected: DNS1 Anycast Network (Europe) and DNS2 Anycast Network (Europe).