Unable to add new organizations on the dashboard

Incident Report for DNSFilter

Resolved

This incident has been resolved. If further assistance is needed please contact us at support@dnsfilter.com.
Posted May 30, 2023 - 16:21 EDT

Monitoring

A fix has been implemented and we are seeing that organizations are now able to be added to the dashboard. We are currently monitoring to ensure there are no further issues.
Posted May 30, 2023 - 14:03 EDT

Investigating

Our engineering team is currently investigating an issue that is preventing users from being able to create new organizations in the dashboard. We will provide updated status as soon as possible.

DNS resolution is operating normally.
Posted May 30, 2023 - 13:35 EDT
This incident affected: Dashboard (Front End UI).