Dashboard Login Access Issues — Monitoring

Incident Report for DNSFilter

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:49 EST

Monitoring

We are currently investigating an issue affecting some users access to the DNSFilter dashboard. This does not impact DNS resolution. We are closely monitoring the situation and will provide updates as more information becomes available.
Posted Nov 18, 2025 - 07:26 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 07:26 EST

Investigating

Our engineering team is currently investigating an issue that is causing DNS resolution to be Intermittent and is currently working with our partners to implement a fix to resolve this problem. Updated status will be provided as soon as possible.
Posted Nov 18, 2025 - 07:20 EST
This incident affected: Dashboard (API).