UPDATE: We have remediated the delayed API responses to the Dashboard and API. Our systems are stable and operating as normal and therefore the incident is being declared as closed. We are continuously monitoring our systems ensuring that there are no potential impacts to our customers.
Thank you for your understanding.
Posted Mar 24, 2025 - 15:32 EDT
Investigating
Affected Systems/Services: Dashboard/API Incident Priority Level: Medium Summary: This announcement is to inform you that we are currently investigating delayed API responses on the Dashboard and API that began at 12:17 UTC on March 24, 2025. There is no impact on Anycast nodes and DNS resolutions. We have stabilized the system and we are monitoring the situation. We understand the potential impact this may have and are working diligently to identify and resolve the delays as quickly as possible. We will provide further updates on our progress as they become available Thank you for your patience and understanding.