Scheduled Maintenance – March 16th, 6:00–6:30 PM EST

Scheduled for Mar 16, 18:00 - 18:30 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 04, 2026 - 10:44 EST

Scheduled

We will be performing scheduled maintenance on March 16th from 6:00 PM to 6:30 PM EST.

During this maintenance window, the following features may be temporarily unavailable:


Previewing Custom Blocked Pages
Display of Logo Thumbnails


DNS resolution and filtering services will not be impacted. All core DNS functionality will continue to operate normally.

We appreciate your patience as we complete this maintenance. If you have any questions, please contact our support team.
Posted Mar 03, 2026 - 16:34 EST
This scheduled maintenance affects: Dashboard (Front End UI).