DNSFilter Dashboard Performance Issue - Identified

Incident Report for DNSFilter

Resolved

We’ve resolved the issue that was causing DNS Query Log data to not appear in the dashboard. Our engineering team identified the root cause and implemented a fix, and data visibility has now been restored.
Posted Apr 27, 2026 - 10:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 08:47 EDT

Identified

Our engineering team has identified an issue where the dashboard may not show data in the DNS Query Log and is currently working to implement a fix to remediate the problem. We will provide updated status as soon as possible once a fix has been implemented.
Posted Apr 27, 2026 - 07:09 EDT
This incident affected: Dashboard (Front End UI).