DNS Resolution is (Down / Intermittent) - Resolved

Incident Report for DNSFilter

Resolved

This incident is now resolved. We have now shifted traffic back to the NYC region.

This issue was identified to be caused by a routing problem at an upstream Internet Exchange provider, which impacted connectivity and cascaded to our services.

To minimize customer impact, we temporarily rerouted traffic to our Washington, DC region. Once the issue was confirmed to be resolved by our upstream partner, traffic was safely restored to the NYC region.
Posted Mar 30, 2026 - 16:13 EDT

Monitoring

Traffic redirection has been completed, and we’ve shifted traffic to the closest available region. Performance should now be returning to normal, if it hasn’t stabilized already. We will continue to monitor closely to ensure stability.
Posted Mar 30, 2026 - 13:26 EDT

Identified

Our Engineering team has identified an issue that has caused DNS resolution failure observed in our NYC region and is actively working to implement a fix to remediate and restore services. Updated status will be provided as soon as possible.
Posted Mar 30, 2026 - 13:02 EDT
This incident affected: DNS1 Anycast Network (North America) and DNS2 Anycast Network (North America).