Blocked pages are not loading properly

Incident Report for DNSFilter

Resolved

This incident has been resolved.
Posted Mar 12, 2024 - 21:13 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2024 - 20:09 EDT

Investigating

We are currently investigating an issue where the block page is intermittently not loading properly. DNS resolution continues as normal. Updated status will be provided as soon as possible.
Posted Mar 12, 2024 - 18:36 EDT
This incident affected: Features (Blocked Page).