Increased Latency in FRA region

Incident Report for DNSFilter

Resolved

This incident has been resolved.
Posted May 07, 2025 - 15:26 EDT

Monitoring

We've identified the root cause of the recent performance degradation. We have implemented a fix for our affected servers from our provider to permanently resolve this issue.

We will continue to monitor performance closely and provide further updates as soon as the additional memory is provisioned. Thank you for your patience as we work to ensure a stable and optimal experience.
Posted May 07, 2025 - 12:48 EDT
This incident affected: DNS1 Anycast Network (Europe) and DNS2 Anycast Network (Europe).